[Firehol-support] Unable to let internal network access the internet via cable modem

John Zastrow br8kwall at yahoo.com
Mon Feb 10 03:58:21 GMT 2003


I've got the classic situation: eth0 on the linux box
connected to a cable modem with dynamic IPs. eth1
points to the internal network, which is currently one
machine. That machine gets its IP from dhcpd and sees
eth1 ( as its gateway. Linux box is
running Redhat8.

I would like to route to the internal machine full
access to the linux box and internet, so I tried the
firehol stock home_adsl config as a start (though I
had to change the path for sysctl to /sbin/sysctl to
stop firehol from complaining). 

Now the linux box sees the internet just fine through
eth0. The internal box is getting its IP and I can ssh
into the linux through eth1 just fine. But, the
internal machine cannot see the internet. I also tried
working through the tutorial config, but that didn't

Nothing seems to be complaining, so it's obviously a
config problem. Where do I start troubleshooting this?
 The troubleshooting section is a little lite in this


Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.

More information about the Firehol-support mailing list